WhatsApp will no longer work on Certain Phones – Here’s the List

WhatsApp will no longer work on Certain Phones – Here’s the List

WhatsApp recently announced that it is removing support for many of old Android and iOS models from 1 November, meaning you will no longer be able to send messages and photos.

Phones to be Affected

From 1 November, 43 smartphone models – both Android and iOS – will lose the ability to send messages and photos or make video calls using the encrypted messaging service.

WhatsApp on Android is coming with THIS redesigned feature - know how it  will affect functioning
Photo/Courtesy

Smartphone models with Android 4.0.4 or earlier installed will become incompatible with WhatsApp and iPhones with iOS 9 or earlier installed.

It means the following phone models will lose access to the app:

  • Samsung Galaxy S3 Mini, Trend II, Trend Lite, Core, Ace 2
  • LG Optimus F7, F5, L3 II Dual, F7 II, F5 II
  • Sony Xperia
  • Huawei Ascend Mate and Ascend D2
  • Apple iPhone SE, 6S, and 6S Plus

WhatsApp has added tons of new features this year – such as disappearing messages, joinable group calls, and stickers. It claims it is phasing out support for these older phones to ensure the app still runs securely.

The messaging app has lost a lot of users over the last year due to ongoing privacy concerns around its new terms of service. WhatsApp has traditionally marketed itself on offering secure, encrypted messaging but announced wildly unpopular changes to the way it handles user data.

Google also announced that it plans to completely end sign-in support for older Android devices this month. That means anyone with a device older than Android 2.3.7 will no longer be able to access basic Google services that make their phones functional.

The functionality for apps like Gmail or YouTube is stopping on September 27, although they will be able to be accessed through the web browser – for devices running Android 2.3.7 or earlier.

Google said: “As part of our ongoing efforts to keep our users safe, Google will no longer allow sign-in on Android devices that run Android 2.3.7 or lower starting September 27, 2021.

“If you sign into your device after September 27, you may get username or password errors when you try to use Google products and services like Gmail, YouTube, and Maps.

“If your device has the ability to update to a newer Android version (3.0+), we advise you to do so in order to maintain access to Google apps and services on that device.”

On its support page, the company continued: “You will be able to sign into your account with a newer Android version (3.0 or newer).

“If your device has the ability to update to a newer Android version (3.0+), we advise you to do so.

“If you cannot update your device to a newer Android version (3.0+), you can try to log into your Google account on your device’s web browser.

“You can still use some Google services when logged into Google on your device’s web browser.”

Leave a Reply

Your email address will not be published. Required fields are marked *